#45 ✓resolved
Johannes Schirge

Webbased database-setup

Reported by Johannes Schirge | 2009-05-08 04:41:41 UTC | in 0.6

Hey based on your new config-file I have created a webbased installer.

Features: - it checks if config-file exists - if config-file exists it proofs connection to the database and checks chmod of folder /config/ (for security reasons) - if connection to database fails -> error message - checks if folders /cache/ and /config/ are set to 777 (for writing the config-file) - formular-based database-settings entry - checks connection to database with the entered settings and only if this works config-file will be written to folder /config/ - if connection fails entered settings are loaded into formular and user can edit them again

If you like it you have to add folder /config/ to the source and have to change the files which links to config.php in base-directory and let them link to config/config.php.

I also defined a constant for global language. Maybe it is possible to set a global language and a user-language so that users can change the language in their profile?

Have a look at it :)

Comments and changes to this ticket

  • Brian Jesse Hendrickson

    Brian Jesse Hendrickson 2009-05-08 10:28:36 UTC

    • State changed from “new” to “open”

    you are one cool dude

  • Brian Jesse Hendrickson

    Brian Jesse Hendrickson 2009-05-08 23:45:26 UTC

    this makes installing a lot of fun! very nice work!

  • Brian Jesse Hendrickson

    Brian Jesse Hendrickson 2009-05-09 22:39:18 UTC

    • State changed from “open” to “resolved”

    thanks Johannes I'm now including your install.php in the download

  • Johannes Schirge

    Johannes Schirge 2009-05-09 23:55:35 UTC

    Thanks!! :-)

    Maybe it is possible to implement the following settings out of /app/config/config.yml to the installation-process?

    environment settings

    env:

    site_title: Latest Updates site_subtitle: site_description:

    theme: p2

    email_from: root@localhost email_name: Notifier email_server: localhost email_port: 25 email_user: email_pass:

    threaded: false (maybe, I don't really know the function ;-) )

    pretty_urls: false

    If its possible I would add them to the install.php. Users may be confused if there are two config-files to be edited.

  • Johannes Schirge

    Johannes Schirge 2009-05-12 23:13:44 UTC

    Important install.php-update!

    • fixed: chmod of created files is now set to 666 (before 644). User wasn't able to change / delete the created file by ftp-client on some servers.

    • fixed: keeps checkbox-settings if connection to database fails and site reloads.

    • new feature: if pretty URLs activated, installer generates a configured .htacces-file to /config/. Also removes line 2 and 3 if used on subdomains.

    • new feature: explanation what to do after installation. (change settings in app/config/config.yml) and move .htaccess to main directory if pretty urls enabled.

  • Johannes Schirge

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

a(nother) PHP implementation of the http://openmicroblogging.org standard for distributed microblogging. Compatible with identi.ca and laconi.ca

Attachments

Pages